Document Emitters (Word, Excel etc.)

The Document Emitters in BIRT use the Apache POI library 3.9 and this version dates back to 2012.

Updating this to a actual version (i.e 4.x) requires two steps:

  • Step 1: get newer POI-Bundles from Eclipse Orbit. I got Apache POI 4.1.1 here: Eclipse Orbit Composite Site R20201130205003
  • Step 2: update Source-Code: Apache changed some constants. Either moving them to other classes or simply renaming them. Also, a few class methods or constructors have been deprecated or even removed. But heads up: there is always a replacement functionality available and as always is Google your friend! The code changes have to be applied to the packages uk.co.spudsoft.birt.emitters and to org.eclipse.birt.report.data.oda.excel.

0 Kommentare

Schreiben Sie einen Kommentar

Avatar placeholder

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.